# CVE-2020-23960: Cross-Site Request Forgery in ForkCMS


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 11 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-pvgf-mrr4-cw7r

## What is CVE-2020-23960?

CVE-2020-23960 is a high-severity vulnerability in n/a, published on 11 Jan 2021. 

### Official description

Multiple cross-site request forgery (CSRF) vulnerabilities in the Admin Console in Fork before 5.8.3 allows remote attackers to perform unauthorized actions as administrator to (1) approve the mass of the user's comments, (2) restoring a deleted user, (3) installing or running modules, (4) resetting the analytics, (5) pinging the mailmotor api, (6) uploading things to the media library, (7) exporting locale.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2020-23960?

2 open source packages ship an affected version, including forkcms/forkcms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `forkcms/forkcms` | Packagist | All versions | 5.8.3 |
| `forkcms/forkcms` | Packagist | All versions | 5.8.3 |

Products: Fork-Cms Fork Cms.

## How do I fix CVE-2020-23960?

Upgrade forkcms/forkcms to 5.8.3 or later.

## Is CVE-2020-23960 being exploited?

There is no known exploitation of CVE-2020-23960 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-15521](https://insights.sbomify.com/CVE-2019-15521/): Spoon Library as used in Fork CMS allows PHP object injection (critical 9.8)
- [CVE-2022-0153](https://insights.sbomify.com/CVE-2022-0153/): SQL Injection in forkcms/forkcms (critical 9.6)
- [CVE-2022-1064](https://insights.sbomify.com/CVE-2022-1064/): SQL injection through marking blog comments on bulk as spam in forkcms/forkcms (critical 9.0)
- [CVE-2021-28931](https://insights.sbomify.com/CVE-2021-28931/): Arbitrary file upload in Fork CMS (high 8.8)
- [CVE-2020-23264](https://insights.sbomify.com/CVE-2020-23264/): Cross-Site Request Forgery in forkcms (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-23960 and fix it if it is affected.

What it is: CVE-2020-23960 is a high-severity vulnerability in n/a, published on 11 Jan 2021. 
Exploitation: There is no known exploitation of CVE-2020-23960 in the wild and no public exploit code.

Affected packages and fixed versions:
- forkcms/forkcms (Packagist): affected all versions; fixed in 5.8.3
- forkcms/forkcms (Packagist): affected all versions; fixed in 5.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-23960/ (Markdown: https://insights.sbomify.com/CVE-2020-23960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-23960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-23960
- OSV: https://osv.dev/vulnerability/CVE-2020-23960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-23960/
Summaries are generated and may contain mistakes; the official description above is the record.
