{"answers":{"affected":"2 open source packages ship an affected version, including node-sass. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-24025 in the wild and no public exploit code.","fix":"Upgrade node-sass to 7.0.0 or later.","what":"CVE-2020-24025 is a medium-severity vulnerability in n/a, published on 11 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-24025 and fix it if it is affected.\n\nWhat it is: CVE-2020-24025 is a medium-severity vulnerability in n/a, published on 11 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-24025 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-sass (npm): affected from 2.0.0; fixed in 7.0.0\n- node-sass (npm): affected from 2.0.0; fixed in 7.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-24025/ (Markdown: https://insights.sbomify.com/CVE-2020-24025/index.md)","id":"CVE-2020-24025","markdown":"https://insights.sbomify.com/CVE-2020-24025/index.md","name":"CVE-2020-24025","record":{"aliases":["AZL-27653","CLSA-2026-1788517165","DEBIAN-CVE-2020-24025","GHSA-r8f7-9pfq-mjmv","UBUNTU-CVE-2020-24025"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js Sass library","requires_auth":"none","summary":"Attackers can bypass certificate validation during binary downloads in node-sass, enabling man-in-the-middle attacks against developers.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"node-sass","vendor":"sass-lang"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Certificate Validation in node-sass","id":"CVE-2020-24025","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-24026"},"packages":[{"ecosystem":"npm","fixed":["7.0.0"],"introduced":["2.0.0"],"last_affected":[],"package":"node-sass","purl":null,"source":"GHSA-r8f7-9pfq-mjmv"},{"ecosystem":"npm","fixed":["7.0.0"],"introduced":["2.0.0"],"last_affected":[],"package":"node-sass","purl":"pkg:npm/node-sass","source":"GHSA-r8f7-9pfq-mjmv"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2020-24020"},"products":["n/a"],"published":"2021-01-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can bypass certificate validation during binary downloads in node-sass, enabling man-in-the-middle attacks against developers.","url":"https://insights.sbomify.com/CVE-2020-24025/"}