{"answers":{"affected":"2 open source packages ship an affected version, including com.taoensso:nippy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-24164 in the wild and no public exploit code.","fix":"Upgrade com.taoensso:nippy to 2.14.2 or later.","what":"CVE-2020-24164 is a high-severity unsafe deserialization vulnerability in n/a, published on 11 Sep 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-24164 and fix it if it is affected.\n\nWhat it is: CVE-2020-24164 is a high-severity unsafe deserialization vulnerability in n/a, published on 11 Sep 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-24164 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.taoensso:nippy (Maven): affected all versions; fixed in 2.14.2\n- com.taoensso:nippy (Maven): affected all versions; fixed in 2.14.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-24164/ (Markdown: https://insights.sbomify.com/CVE-2020-24164/index.md)","id":"CVE-2020-24164","markdown":"https://insights.sbomify.com/CVE-2020-24164/index.md","name":"CVE-2020-24164","record":{"aliases":["GHSA-p5gm-fgfx-hr7h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java serialization library","requires_auth":"none","summary":"Attackers can execute arbitrary code via malicious payloads due to unsafe Java deserialization in the Nippy library.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"nippy","vendor":"taoensso"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A deserialization flaw is present in Taoensso Nippy before 2.14.2. In some circumstances, it is possible for an attacker to create a malicious payload that, when deserialized, will allow arbitrary code to be executed. This occurs because there is automatic use of the Java Serializable interface.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Gadget chain attack in Nippy","id":"CVE-2020-24164","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"Other in n/a","id":"CVE-2020-24165"},"packages":[{"ecosystem":"Maven","fixed":["2.14.2"],"introduced":["0"],"last_affected":[],"package":"com.taoensso:nippy","purl":null,"source":"GHSA-p5gm-fgfx-hr7h"},{"ecosystem":"Maven","fixed":["2.14.2"],"introduced":["0"],"last_affected":[],"package":"com.taoensso:nippy","purl":"pkg:maven/com.taoensso/nippy","source":"GHSA-p5gm-fgfx-hr7h"}],"prev":{"headline":"Other in n/a","id":"CVE-2020-24162"},"products":["n/a"],"published":"2020-09-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via malicious payloads due to unsafe Java deserialization in the Nippy library.","url":"https://insights.sbomify.com/CVE-2020-24164/"}