# CVE-2020-24164: Gadget chain attack in Nippy

> Attackers can execute arbitrary code via malicious payloads due to unsafe Java deserialization in the Nippy library.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-p5gm-fgfx-hr7h

## What is CVE-2020-24164?

CVE-2020-24164 is a high-severity unsafe deserialization vulnerability in n/a, published on 11 Sep 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A deserialization flaw is present in Taoensso Nippy before 2.14.2. In some circumstances, it is possible for an attacker to create a malicious payload that, when deserialized, will allow arbitrary code to be executed. This occurs because there is automatic use of the Java Serializable interface.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-24164?

2 open source packages ship an affected version, including com.taoensso:nippy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.taoensso:nippy` | Maven | All versions | 2.14.2 |
| `com.taoensso:nippy` | Maven | All versions | 2.14.2 |

Products: Taoensso Nippy.

## How do I fix CVE-2020-24164?

Upgrade com.taoensso:nippy to 2.14.2 or later.

## Is CVE-2020-24164 being exploited?

There is no known exploitation of CVE-2020-24164 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24164 and fix it if it is affected.

What it is: CVE-2020-24164 is a high-severity unsafe deserialization vulnerability in n/a, published on 11 Sep 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-24164 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.taoensso:nippy (Maven): affected all versions; fixed in 2.14.2
- com.taoensso:nippy (Maven): affected all versions; fixed in 2.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24164/ (Markdown: https://insights.sbomify.com/CVE-2020-24164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24164
- OSV: https://osv.dev/vulnerability/CVE-2020-24164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24164/
Summaries are generated and may contain mistakes; the official description above is the record.
