# CVE-2020-24359: Improper Input Validation in vault-ssh-helper

> Attackers can use SSH OTPs for any IP in the host's subnet, bypassing specific IP restrictions in HashiCorp Vault SSH helper.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-f9fq-vjvh-779p, GO-2022-0824

## What is CVE-2020-24359?

CVE-2020-24359 is a high-severity authentication bypass vulnerability in n/a, published on 20 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp vault-ssh-helper up to and including version 0.1.6 incorrectly accepted Vault-issued SSH OTPs for the subnet in which a host's network interface was located, rather than the specific IP address assigned to that interface. Fixed in 0.2.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-24359?

3 open source packages ship an affected version, including github.com/hashicorp/vault-ssh-helper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault-ssh-helper` | Go | All versions | 0.2.0 |
| `github.com/hashicorp/vault-ssh-helper` | Go | All versions | 0.2.0 |
| `github.com/hashicorp/vault-ssh-helper` | Go | All versions | 0.2.0 |

Products: Hashicorp Vault-Ssh-Helper.

## How do I fix CVE-2020-24359?

Upgrade github.com/hashicorp/vault-ssh-helper to 0.2.0 or later.

## Is CVE-2020-24359 being exploited?

There is no known exploitation of CVE-2020-24359 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24359 and fix it if it is affected.

What it is: CVE-2020-24359 is a high-severity authentication bypass vulnerability in n/a, published on 20 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-24359 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault-ssh-helper (Go): affected all versions; fixed in 0.2.0
- github.com/hashicorp/vault-ssh-helper (Go): affected all versions; fixed in 0.2.0
- github.com/hashicorp/vault-ssh-helper (Go): affected all versions; fixed in 0.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24359/ (Markdown: https://insights.sbomify.com/CVE-2020-24359/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24359
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24359
- OSV: https://osv.dev/vulnerability/CVE-2020-24359

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24359/
Summaries are generated and may contain mistakes; the official description above is the record.
