# CVE-2020-24371: Memory corruption in n/a

> A memory access violation in Lua's garbage collector allows attackers to cause denial of service or potentially execute arbitrary code.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-40962, BIT-lua-2020-24371, DEBIAN-CVE-2020-24371, GHSA-4m5p-2hm8-9fxm

## What is CVE-2020-24371?

CVE-2020-24371 is a medium-severity memory corruption vulnerability in n/a, published on 17 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lgc.c in Lua 5.4.0 mishandles the interaction between barriers and the sweep phase, leading to a memory access violation involving collectgarbage.

Weakness: CWE-763 (Release of Invalid Pointer or Reference)

## Which versions are affected by CVE-2020-24371?

1 open source package ship an affected version, including lua. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lua` | Bitnami | From 5.4.0 | 5.4.1 |

Products: Lua Lua.

## How do I fix CVE-2020-24371?

Upgrade lua to 5.4.1 or later.

## Is CVE-2020-24371 being exploited?

There is no known exploitation of CVE-2020-24371 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-15889](https://insights.sbomify.com/CVE-2020-15889/): Memory corruption in n/a (critical 9.8)
- [CVE-2020-15888](https://insights.sbomify.com/CVE-2020-15888/): Use after free in n/a (high 8.8)
- [CVE-2021-45985](https://insights.sbomify.com/CVE-2021-45985/): Memory corruption in n/a (high 7.5)
- [CVE-2020-24369](https://insights.sbomify.com/CVE-2020-24369/): Null dereference in n/a (high 7.5)
- [CVE-2021-44964](https://insights.sbomify.com/CVE-2021-44964/): Use after free in n/a (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24371 and fix it if it is affected.

What it is: CVE-2020-24371 is a medium-severity memory corruption vulnerability in n/a, published on 17 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-24371 in the wild and no public exploit code.

Affected packages and fixed versions:
- lua (Bitnami): affected from 5.4.0; fixed in 5.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24371/ (Markdown: https://insights.sbomify.com/CVE-2020-24371/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24371
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24371
- OSV: https://osv.dev/vulnerability/CVE-2020-24371

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24371/
Summaries are generated and may contain mistakes; the official description above is the record.
