CVE-2020-24400 SQL injection allows arbitrary read from database
Authenticated users with product listing permissions can exploit SQL injection to read sensitive data from the Magento database.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-24400?
CVE-2020-24400 is a high-severity SQL injection vulnerability in Magento Magento, published on 9 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Magento versions 2.4.0 and 2.3.5 (and earlier) are affected by an SQL Injection vulnerability that could lead to sensitive information disclosure. This vulnerability could be exploited by an authenticated user with permissions to the product listing page to read data from the database.
Weakness: CWE-89
Which versions are affected by CVE-2020-24400?
5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.6 |
magento/community-edition Packagist | All versions | 2.3.6 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1 |
magento Bitnami | All versions | 2.3.5, 2.4.1 |
Products include Magento Magento.
How do I fix CVE-2020-24400?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.6 or 2.4.1.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2020-24400 being exploited?
There is no known exploitation of CVE-2020-24400 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2020-24400, GHSA-pf6w-3pfw-fxvw.