# CVE-2020-24400: SQL injection allows arbitrary read from database

> Authenticated users with product listing permissions can exploit SQL injection to read sensitive data from the Magento database.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2020
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-magento-2020-24400, GHSA-pf6w-3pfw-fxvw

## What is CVE-2020-24400?

CVE-2020-24400 is a high-severity SQL injection vulnerability in Magento Magento, published on 9 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Magento versions 2.4.0 and 2.3.5 (and earlier) are affected by an SQL Injection vulnerability that could lead to sensitive information disclosure. This vulnerability could be exploited by an authenticated user with permissions to the product listing page to read data from the database.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-24400?

5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | 2.3.6 |
| `magento/community-edition` | Packagist | All versions | 2.3.6 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.1 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.1 |
| `magento` | Bitnami | All versions | 2.3.5, 2.4.1 |

Products: Magento Magento.

## How do I fix CVE-2020-24400?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.6 or 2.4.1.

## Is CVE-2020-24400 being exploited?

There is no known exploitation of CVE-2020-24400 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24400 and fix it if it is affected.

What it is: CVE-2020-24400 is a high-severity SQL injection vulnerability in Magento Magento, published on 9 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-24400 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.1
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.1
- magento (Bitnami): affected all versions; fixed in 2.3.5, 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24400/ (Markdown: https://insights.sbomify.com/CVE-2020-24400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24400
- OSV: https://osv.dev/vulnerability/CVE-2020-24400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24400/
Summaries are generated and may contain mistakes; the official description above is the record.
