CVE-2020-24401 Incorrect permissions following the deletion of a user role or deactivation of a user
Deactivated users or those with removed roles retain access to previously provisioned resources, allowing unauthorized data access or modification.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-24401?
CVE-2020-24401 is a medium-severity missing authorization vulnerability in Magento Magento, published on 9 Nov 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Magento versions 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect authorization vulnerability. A user can still access resources provisioned under their old role after an administrator removes the role or disables the user's account.
Weakness: CWE-863
Which versions are affected by CVE-2020-24401?
5 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.4.1 |
magento/community-edition Packagist | All versions | 2.4.1 |
magento Bitnami | All versions | 2.3.5, 2.4.1 |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Magento Magento.
How do I fix CVE-2020-24401?
Upgrade magento/community-edition to 2.4.1 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2020-24401 being exploited?
There is no known exploitation of CVE-2020-24401 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2020-24401, GHSA-f2g3-3c6q-4478.