CVE-2020-24404 Incorrect permissions in Integrations component could lead to unauthorized deletion of cmsPages via REST API
Users with page permissions can unauthorizedly delete CMS pages via the REST API due to incorrect permission checks in the Integrations component.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-24404?
CVE-2020-24404 is a low-severity missing authorization vulnerability in Magento Magento, published on 9 Nov 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect permissions vulnerability within the Integrations component. This vulnerability could be abused by users with permissions to the Pages resource to delete cms pages via the REST API without authorization.
Weakness: CWE-285
Which versions are affected by CVE-2020-24404?
5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.6 |
magento/community-edition Packagist | All versions | 2.3.6 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1 |
magento Bitnami | All versions | 2.3.5, 2.4.1 |
Products include Magento Magento.
How do I fix CVE-2020-24404?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.6 or 2.4.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2020-24404 being exploited?
There is no known exploitation of CVE-2020-24404 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2020-24404, GHSA-rwf7-652f-76mv.