{"answers":{"affected":"5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-24404 in the wild and no public exploit code.","fix":"Upgrade magento/community-edition to a fixed version for your release line: 2.3.6 or 2.4.1.","what":"CVE-2020-24404 is a low-severity missing authorization vulnerability in Magento Magento, published on 9 Nov 2020. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-24404 and fix it if it is affected.\n\nWhat it is: CVE-2020-24404 is a low-severity missing authorization vulnerability in Magento Magento, published on 9 Nov 2020. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-24404 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6\n- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6\n- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.1\n- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.1\n- magento (Bitnami): affected all versions; fixed in 2.3.5, 2.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-24404/ (Markdown: https://insights.sbomify.com/CVE-2020-24404/index.md)","id":"CVE-2020-24404","markdown":"https://insights.sbomify.com/CVE-2020-24404/index.md","name":"CVE-2020-24404","record":{"aliases":["BIT-magento-2020-24404","GHSA-rwf7-652f-76mv"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento e-commerce platform","requires_auth":"high_privilege","summary":"Users with page permissions can unauthorizedly delete CMS pages via the REST API due to incorrect permission checks in the Integrations component.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"magento","vendor":"magento"}],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect permissions vulnerability within the Integrations component. This vulnerability could be abused by users with permissions to the Pages resource to delete cms pages via the REST API without authorization.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect permissions in Integrations component could lead to unauthorized deletion of cmsPages via REST API","id":"CVE-2020-24404","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"magento:magento","products":["magento:magento"],"type":"missing_authorization","year":"2020"},"n_packages":5,"n_references":1,"next":{"headline":"Incorrect permissions in Inventory module could lead to unauthorized modification of inventory stock data","id":"CVE-2020-24405"},"packages":[{"ecosystem":"Bitnami","fixed":["2.3.5","2.4.1"],"introduced":["0","2.4.0"],"last_affected":[],"package":"magento","purl":"pkg:bitnami/magento","source":"BIT-magento-2020-24404"},{"ecosystem":"Packagist","fixed":["2.3.6"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-rwf7-652f-76mv"},{"ecosystem":"Packagist","fixed":["2.3.6"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-rwf7-652f-76mv"},{"ecosystem":"Packagist","fixed":["2.4.1"],"introduced":["2.4.0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-rwf7-652f-76mv"},{"ecosystem":"Packagist","fixed":["2.4.1"],"introduced":["2.4.0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-rwf7-652f-76mv"}],"prev":{"headline":"Incorrect permissions could lead to unauthorized modification of inventory source data via REST API","id":"CVE-2020-24403"},"products":["Magento Commerce"],"published":"2020-11-09","related":[{"cvss_score":9.8,"headline":"Magento php object injection vulnerability","id":"CVE-2020-9664","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9576","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9578","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9579","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9580","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9582","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9583","kev_date_added":null,"published":"2020-06-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Adobe"]},"summary":"Users with page permissions can unauthorizedly delete CMS pages via the REST API due to incorrect permission checks in the Integrations component.","url":"https://insights.sbomify.com/CVE-2020-24404/"}