# CVE-2020-24404: Incorrect permissions in Integrations component could lead to unauthorized deletion of cmsPages via REST API

> Users with page permissions can unauthorizedly delete CMS pages via the REST API due to incorrect permission checks in the Integrations component.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2020
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-magento-2020-24404, GHSA-rwf7-652f-76mv

## What is CVE-2020-24404?

CVE-2020-24404 is a low-severity missing authorization vulnerability in Magento Magento, published on 9 Nov 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect permissions vulnerability within the Integrations component. This vulnerability could be abused by users with permissions to the Pages resource to delete cms pages via the REST API without authorization.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2020-24404?

5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | 2.3.6 |
| `magento/community-edition` | Packagist | All versions | 2.3.6 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.1 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.1 |
| `magento` | Bitnami | All versions | 2.3.5, 2.4.1 |

Products: Magento Magento.

## How do I fix CVE-2020-24404?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.6 or 2.4.1.

## Is CVE-2020-24404 being exploited?

There is no known exploitation of CVE-2020-24404 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24404 and fix it if it is affected.

What it is: CVE-2020-24404 is a low-severity missing authorization vulnerability in Magento Magento, published on 9 Nov 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-24404 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.1
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.1
- magento (Bitnami): affected all versions; fixed in 2.3.5, 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24404/ (Markdown: https://insights.sbomify.com/CVE-2020-24404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24404
- OSV: https://osv.dev/vulnerability/CVE-2020-24404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24404/
Summaries are generated and may contain mistakes; the official description above is the record.
