CVE-2020-24405 Incorrect permissions in Inventory module could lead to unauthorized modification of inventory stock data
Authenticated users can modify inventory stock data without proper authorization due to incorrect permissions in the Magento Inventory module.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-24405?
CVE-2020-24405 is a medium-severity missing authorization vulnerability in Magento Magento, published on 9 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect permissions issue vulnerability in the Inventory module. This vulnerability could be abused by authenticated users to modify inventory stock data without authorization.
Weakness: CWE-285
Which versions are affected by CVE-2020-24405?
5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.6 |
magento/community-edition Packagist | All versions | 2.3.6 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1 |
magento Bitnami | All versions | 2.3.5, 2.4.1 |
Products include Magento Magento.
How do I fix CVE-2020-24405?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.6 or 2.4.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2020-24405 being exploited?
There is no known exploitation of CVE-2020-24405 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2020-24405, GHSA-p7m7-j8jv-393q.