CVE-2020-24407 Arbitrary code execution via file import functionality
Authenticated administrators can achieve arbitrary code execution via unsafe file upload in the import functionality.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-24407?
CVE-2020-24407 is a critical vulnerability in Magento Magento, published on 9 Nov 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Magento versions 2.4.0 and 2.3.5p1 (and earlier) are affected by an unsafe file upload vulnerability that could result in arbitrary code execution. This vulnerability could be abused by authenticated users with administrative permissions to the System/Data and Transfer/Import components.
Weakness: CWE-434
Which versions are affected by CVE-2020-24407?
5 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.4.1 |
magento/community-edition Packagist | All versions | 2.4.1 |
magento Bitnami | All versions | 2.3.5, 2.4.1 |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Magento Magento.
How do I fix CVE-2020-24407?
Upgrade magento/community-edition to 2.4.1 or later.
Is CVE-2020-24407 being exploited?
There is no known exploitation of CVE-2020-24407 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2020-24407, GHSA-7pxg-6p87-8c9v.