# CVE-2020-24407: Arbitrary code execution via file import functionality

> Authenticated administrators can achieve arbitrary code execution via unsafe file upload in the import functionality.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2020
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-magento-2020-24407, GHSA-7pxg-6p87-8c9v

## What is CVE-2020-24407?

CVE-2020-24407 is a critical vulnerability in Magento Magento, published on 9 Nov 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Magento versions 2.4.0 and 2.3.5p1 (and earlier) are affected by an unsafe file upload vulnerability that could result in arbitrary code execution. This vulnerability could be abused by authenticated users with administrative permissions to the System/Data and Transfer/Import components.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2020-24407?

5 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | 2.4.1 |
| `magento/community-edition` | Packagist | All versions | 2.4.1 |
| `magento` | Bitnami | All versions | 2.3.5, 2.4.1 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Magento Magento.

## How do I fix CVE-2020-24407?

Upgrade magento/community-edition to 2.4.1 or later.

## Is CVE-2020-24407 being exploited?

There is no known exploitation of CVE-2020-24407 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24407 and fix it if it is affected.

What it is: CVE-2020-24407 is a critical vulnerability in Magento Magento, published on 9 Nov 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-24407 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; fixed in 2.4.1
- magento/community-edition (Packagist): affected all versions; fixed in 2.4.1
- magento (Bitnami): affected all versions; fixed in 2.3.5, 2.4.1
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24407/ (Markdown: https://insights.sbomify.com/CVE-2020-24407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24407
- OSV: https://osv.dev/vulnerability/CVE-2020-24407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24407/
Summaries are generated and may contain mistakes; the official description above is the record.
