# CVE-2020-24553: Cross-site scripting in n/a

> Cross-site scripting vulnerability in Go's CGI/FCGI handlers allows attackers to inject scripts when Content-Type headers are missing.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-79064, AZL-98880, BIT-golang-2020-24553, DEBIAN-CVE-2020-24553, GHSA-pfr3-j9r8-5229, GO-2021-0226, MGASA-2020-0424, SUSE-SU-2020:2761-1, SUSE-SU-2020:2776-1, UBUNTU-CVE-2020-24553, USN-4758-1, openSUSE-SU-2020:1584-1, openSUSE-SU-2020:1587-1

## What is CVE-2020-24553?

CVE-2020-24553 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Go before 1.14.8 and 1.15.x before 1.15.1 allows XSS because text/html is the default for CGI/FCGI handlers that lack a Content-Type header.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-24553?

2 open source packages ship an affected version, including golang and stdlib. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `golang` | Bitnami | All versions | 1.14.8, 1.15.1 |
| `stdlib` | Go | All versions | 1.14.8, 1.15.1 |
| `go1.14` | SUSE:Linux Enterprise Module for Development Tools 15 SP1 | All versions | 1.14.9-1.18.1 |
| `go1.15` | SUSE:Linux Enterprise Module for Development Tools 15 SP1 | All versions | 1.15.2-1.3.1 |
| `go1.14` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 1.14.9-1.18.1 |
| `go1.15` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 1.15.2-1.3.1 |
| `go1.14` | openSUSE:Leap 15.1 | All versions | 1.14.9-lp151.16.1 |
| `go1.14` | openSUSE:Leap 15.2 | All versions | 1.14.9-lp152.2.6.1 |

Products: Fedoraproject Fedora, Golang Go, Opensuse Leap, Oracle Communications Cloud Native Core Policy.

## How do I fix CVE-2020-24553?

Upgrade golang to a fixed version for your release line: 1.14.8 or 1.15.1.

## Is CVE-2020-24553 being exploited?

There is no known exploitation of CVE-2020-24553 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24553 and fix it if it is affected.

What it is: CVE-2020-24553 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-24553 in the wild and no public exploit code.

Affected packages and fixed versions:
- golang (Bitnami): affected all versions; fixed in 1.14.8, 1.15.1
- stdlib (Go): affected all versions; fixed in 1.14.8, 1.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24553/ (Markdown: https://insights.sbomify.com/CVE-2020-24553/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24553
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24553
- OSV: https://osv.dev/vulnerability/CVE-2020-24553

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24553/
Summaries are generated and may contain mistakes; the official description above is the record.
