# CVE-2020-24583: Django Incorrect Default Permissions

> Django fails to apply directory permissions to intermediate upload and static directories, potentially exposing sensitive files to unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-24583, BIT-django-2020-24583, DEBIAN-CVE-2020-24583, GHSA-m6gj-h9gm-gw44, PYSEC-2020-33, UBUNTU-CVE-2020-24583

## What is CVE-2020-24583?

CVE-2020-24583 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 2.2 before 2.2.16, 3.0 before 3.0.10, and 3.1 before 3.1.1 (when Python 3.7+ is used). FILE_UPLOAD_DIRECTORY_PERMISSIONS mode was not applied to intermediate-level directories created in the process of uploading files. It was also not applied to intermediate-level collected static directories when using the collectstatic management command.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2020-24583?

8 open source packages ship an affected version, including django and Django. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 2.2.0 | 2.2.16, 3.0.10, 3.1.1 |
| `django` | PyPI | From 2.2 | 2.2.16, 3.0.10, 3.1.1 |
| `django` | PyPI | From 2.2a1 | 2.2.16 |
| `django` | PyPI | From 3.0a1 | 3.0.10 |
| `django` | PyPI | From 3.1a1 | 3.1.1 |
| `Django` | PyPI | From 2.2a1 | 2.2.16 |
| `Django` | PyPI | From 3.0a1 | 3.0.10 |
| `Django` | PyPI | From 3.1a1 | 3.1.1 |

Products: Canonical Ubuntu Linux, Djangoproject Django, Fedoraproject Fedora, Oracle Zfs Storage Appliance Kit.

## How do I fix CVE-2020-24583?

Upgrade django to a fixed version for your release line: 2.2.16, 3.0.10 or 3.1.1.

## Is CVE-2020-24583 being exploited?

There is no known exploitation of CVE-2020-24583 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24583 and fix it if it is affected.

What it is: CVE-2020-24583 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-24583 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 2.2.0; fixed in 2.2.16, 3.0.10, 3.1.1
- django (PyPI): affected from 2.2; fixed in 2.2.16, 3.0.10, 3.1.1
- django (PyPI): affected from 2.2a1; fixed in 2.2.16
- django (PyPI): affected from 3.0a1; fixed in 3.0.10
- django (PyPI): affected from 3.1a1; fixed in 3.1.1
- Django (PyPI): affected from 2.2a1; fixed in 2.2.16
- Django (PyPI): affected from 3.0a1; fixed in 3.0.10
- Django (PyPI): affected from 3.1a1; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24583/ (Markdown: https://insights.sbomify.com/CVE-2020-24583/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24583
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24583
- OSV: https://osv.dev/vulnerability/CVE-2020-24583

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24583/
Summaries are generated and may contain mistakes; the official description above is the record.
