CVE-2020-24584 Django Incorrect Default Permissions
Django's filesystem cache used insecure directory permissions, potentially allowing local attackers to read cached data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-24584?
CVE-2020-24584 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Django 2.2 before 2.2.16, 3.0 before 3.0.10, and 3.1 before 3.1.1 (when Python 3.7+ is used). The intermediate-level directories of the filesystem cache had the system's standard umask rather than 0o077.
Weakness: CWE-276
Which versions are affected by CVE-2020-24584?
8 open source packages ship an affected version, including django and Django. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 2.2.0 | 2.2.16, 3.0.10, 3.1.1 |
django PyPI | From 2.2 | 2.2.16, 3.0.10, 3.1.1 |
django PyPI | From 2.2 | 2.2.16 |
django PyPI | From 3.0 | 3.0.10 |
django PyPI | From 3.1 | 3.1.1 |
Django PyPI | From 2.2 | 2.2.16 |
2 more packages
Django PyPI | From 3.0 | 3.0.10 |
Django PyPI | From 3.1 | 3.1.1 |
Products include Canonical Ubuntu Linux, Djangoproject Django, Fedoraproject Fedora, Oracle Zfs Storage Appliance Kit.
How do I fix CVE-2020-24584?
Upgrade django to a fixed version for your release line: 2.2.16, 3.0.10 or 3.1.1.
Is CVE-2020-24584 being exploited?
There is no known exploitation of CVE-2020-24584 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as ALPINE-CVE-2020-24584, BIT-django-2020-24584, DEBIAN-CVE-2020-24584, GHSA-fr28-569j-53c4, PYSEC-2020-34, UBUNTU-CVE-2020-24584.