{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2020-24614 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-24614 is a high-severity missing authorization vulnerability in Fedoraproject Fedora, published on 25 Aug 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-24614 and fix it if it is affected.\n\nWhat it is: CVE-2020-24614 is a high-severity missing authorization vulnerability in Fedoraproject Fedora, published on 25 Aug 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-24614 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-24614/ (Markdown: https://insights.sbomify.com/CVE-2020-24614/index.md)","id":"CVE-2020-24614","markdown":"https://insights.sbomify.com/CVE-2020-24614/index.md","name":"CVE-2020-24614","record":{"aliases":["DEBIAN-CVE-2020-24614","GHSA-83fw-5hmv-mmqf","MGASA-2020-0354","UBUNTU-CVE-2020-24614","openSUSE-SU-2020:1478-1","openSUSE-SU-2021:1070-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Fossil SCM","requires_auth":"low_privilege","summary":"Authenticated users with check-in privileges can execute arbitrary code in Fossil SCM due to missing authorization checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"fossil","vendor":"fossil-scm"},{"product":"backports_sle","vendor":"opensuse"},{"product":"leap","vendor":"opensuse"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Fossil before 2.10.2, 2.11.x before 2.11.2, and 2.12.x before 2.12.1 allows remote authenticated users to execute arbitrary code. An attacker must have check-in privileges on the repository.","ecosystems":["SUSE:Package Hub 15 SP1","SUSE:Package Hub 15 SP2","openSUSE:Leap 15.1","openSUSE:Leap 15.2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing authorization in n/a","id":"CVE-2020-24614","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:backports_sle","opensuse:leap"],"type":"missing_authorization","year":"2020"},"n_packages":5,"n_references":8,"next":{"headline":"Denial of service in n/a","id":"CVE-2020-24615"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP1","fixed":["2.12.1-bp152.2.3.1"],"introduced":["0"],"last_affected":[],"package":"fossil","purl":"pkg:rpm/suse/fossil\u0026distro=SUSE%20Package%20Hub%2015%20SP1","source":"openSUSE-SU-2020:1478-1"},{"ecosystem":"SUSE:Package Hub 15 SP2","fixed":["2.12.1-bp152.2.3.1"],"introduced":["0"],"last_affected":[],"package":"fossil","purl":"pkg:rpm/suse/fossil\u0026distro=SUSE%20Package%20Hub%2015%20SP2","source":"openSUSE-SU-2020:1478-1"},{"ecosystem":"SUSE:Package Hub 15 SP2","fixed":["2.12.1-bp152.2.9.1"],"introduced":["0"],"last_affected":[],"package":"fossil","purl":"pkg:rpm/suse/fossil\u0026distro=SUSE%20Package%20Hub%2015%20SP2","source":"openSUSE-SU-2021:1070-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["2.12.1-bp152.2.3.1"],"introduced":["0"],"last_affected":[],"package":"fossil","purl":"pkg:rpm/opensuse/fossil\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2020:1478-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["2.12.1-bp152.2.3.1"],"introduced":["0"],"last_affected":[],"package":"fossil","purl":"pkg:rpm/opensuse/fossil\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2020:1478-1"}],"prev":{"headline":"wolfSSL before 4.5.0 mishandles TLS 1.3 server data in the WAIT_CERT_CR state, within SanityCheckTls13MsgReceived() in tls13.c.","id":"CVE-2020-24613"},"products":["n/a"],"published":"2020-08-25","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Authenticated users with check-in privileges can execute arbitrary code in Fossil SCM due to missing authorization checks.","url":"https://insights.sbomify.com/CVE-2020-24614/"}