# CVE-2020-24714: Scalyr Agent Missing SSL Certificate Validation

> The Scalyr Agent fails to validate SSL certificates in certain scenarios, allowing attackers to bypass security checks and potentially intercept traffic.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-w6xv-mf6f-r5f6, PYSEC-2020-251

## What is CVE-2020-24714?

CVE-2020-24714 is a critical vulnerability in n/a, published on 27 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Scalyr Agent before 2.1.10 has Missing SSL Certificate Validation because, in some circumstances, the openssl binary is called without the -verify_hostname option.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2020-24714?

3 open source packages ship an affected version, including scalyr-agent-2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `scalyr-agent-2` | PyPI | All versions | 2.1.10 |
| `scalyr-agent-2` | PyPI | All versions | 2.1.10 |
| `scalyr-agent-2` | PyPI | All versions | 2.1.10 |

Products: Scalyr Scalyr Agent.

## How do I fix CVE-2020-24714?

Upgrade scalyr-agent-2 to 2.1.10 or later.

## Is CVE-2020-24714 being exploited?

There is no known exploitation of CVE-2020-24714 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-24715](https://insights.sbomify.com/CVE-2020-24715/): Scalyr Agent 2 Missing SSL Certificate Validation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24714 and fix it if it is affected.

What it is: CVE-2020-24714 is a critical vulnerability in n/a, published on 27 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-24714 in the wild and no public exploit code.

Affected packages and fixed versions:
- scalyr-agent-2 (PyPI): affected all versions; fixed in 2.1.10
- scalyr-agent-2 (PyPI): affected all versions; fixed in 2.1.10
- scalyr-agent-2 (PyPI): affected all versions; fixed in 2.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24714/ (Markdown: https://insights.sbomify.com/CVE-2020-24714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24714
- OSV: https://osv.dev/vulnerability/CVE-2020-24714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24714/
Summaries are generated and may contain mistakes; the official description above is the record.
