{"answers":{"affected":"2 open source packages ship an affected version, including @easy-team/easywebpack-cli. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-24855 in the wild and no public exploit code.","fix":"Upgrade @easy-team/easywebpack-cli to 4.5.2 or later.","what":"CVE-2020-24855 is a medium-severity path traversal vulnerability in n/a, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-24855 and fix it if it is affected.\n\nWhat it is: CVE-2020-24855 is a medium-severity path traversal vulnerability in n/a, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-24855 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @easy-team/easywebpack-cli (npm): affected all versions; fixed in 4.5.2\n- @easy-team/easywebpack-cli (npm): affected all versions; fixed in 4.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-24855/ (Markdown: https://insights.sbomify.com/CVE-2020-24855/index.md)","id":"CVE-2020-24855","markdown":"https://insights.sbomify.com/CVE-2020-24855/index.md","name":"CVE-2020-24855","record":{"aliases":["GHSA-252h-2cmq-pmr6"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"easywebpack-cli","requires_auth":"none","summary":"Attackers can obtain sensitive information via crafted GET requests in easywebpack-cli, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"easywebpack-cli","vendor":"easyjs"}],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory Traversal vulnerability in easywebpack-cli before 4.5.2 allows attackers to obtain sensitive information via crafted GET request.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"easywebpack-cli Path Traversal vulnerability","id":"CVE-2020-24855","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-24857"},"packages":[{"ecosystem":"npm","fixed":["4.5.2"],"introduced":["0"],"last_affected":[],"package":"@easy-team/easywebpack-cli","purl":null,"source":"GHSA-252h-2cmq-pmr6"},{"ecosystem":"npm","fixed":["4.5.2"],"introduced":["0"],"last_affected":[],"package":"@easy-team/easywebpack-cli","purl":"pkg:npm/%40easy-team/easywebpack-cli","source":"GHSA-252h-2cmq-pmr6"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2020-24849"},"products":["n/a"],"published":"2022-12-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-12","vendors":["n/a"]},"summary":"Attackers can obtain sensitive information via crafted GET requests in easywebpack-cli, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2020-24855/"}