# CVE-2020-24855: easywebpack-cli Path Traversal vulnerability

> Attackers can obtain sensitive information via crafted GET requests in easywebpack-cli, requiring an upgrade to mitigate.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2022
- **Updated:** 12 May 2025
- **Also known as:** GHSA-252h-2cmq-pmr6

## What is CVE-2020-24855?

CVE-2020-24855 is a medium-severity path traversal vulnerability in n/a, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory Traversal vulnerability in easywebpack-cli before 4.5.2 allows attackers to obtain sensitive information via crafted GET request.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-24855?

2 open source packages ship an affected version, including @easy-team/easywebpack-cli. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@easy-team/easywebpack-cli` | npm | All versions | 4.5.2 |
| `@easy-team/easywebpack-cli` | npm | All versions | 4.5.2 |

Products: Easyjs Easywebpack-Cli.

## How do I fix CVE-2020-24855?

Upgrade @easy-team/easywebpack-cli to 4.5.2 or later.

## Is CVE-2020-24855 being exploited?

There is no known exploitation of CVE-2020-24855 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24855 and fix it if it is affected.

What it is: CVE-2020-24855 is a medium-severity path traversal vulnerability in n/a, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-24855 in the wild and no public exploit code.

Affected packages and fixed versions:
- @easy-team/easywebpack-cli (npm): affected all versions; fixed in 4.5.2
- @easy-team/easywebpack-cli (npm): affected all versions; fixed in 4.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24855/ (Markdown: https://insights.sbomify.com/CVE-2020-24855/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24855
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24855
- OSV: https://osv.dev/vulnerability/CVE-2020-24855

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24855/
Summaries are generated and may contain mistakes; the official description above is the record.
