# CVE-2020-24912: qcubed reflected cross-site scripting (XSS) vulnerability

> Unauthenticated attackers can execute arbitrary scripts in victim browsers via profile.php to steal session cookies and take over accounts.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Mar 2021
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-xj4v-gp4q-h6qq

## What is CVE-2020-24912?

CVE-2020-24912 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A reflected cross-site scripting (XSS) vulnerability in qcubed (all versions including 3.1.1) in profile.php via the stQuery-parameter allows unauthenticated attackers to steal sessions of authenticated users.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-24912?

2 open source packages ship an affected version, including qcubed/qcubed. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qcubed/qcubed` | Packagist | All versions | 3.2 |
| `qcubed/qcubed` | Packagist | All versions | 3.2 |

Products: Qcubed Qcubed.

## How do I fix CVE-2020-24912?

Upgrade qcubed/qcubed to 3.2 or later.

## Is CVE-2020-24912 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-24912 exists.

Public exploit code:

- QCube Cross-Site-Scripting (nuclei): http/cves/2020/CVE-2020-24912.yaml

## Other vulnerabilities in n/a

- [CVE-2020-24913](https://insights.sbomify.com/CVE-2020-24913/): qcubed SQL injection vulnerability in profile.php via the strQuery parameter (critical 9.8)
- [CVE-2020-24914](https://insights.sbomify.com/CVE-2020-24914/): qcubed PHP object injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24912 and fix it if it is affected.

What it is: CVE-2020-24912 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-24912 exists.

Affected packages and fixed versions:
- qcubed/qcubed (Packagist): affected all versions; fixed in 3.2
- qcubed/qcubed (Packagist): affected all versions; fixed in 3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24912/ (Markdown: https://insights.sbomify.com/CVE-2020-24912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24912
- OSV: https://osv.dev/vulnerability/CVE-2020-24912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24912/
Summaries are generated and may contain mistakes; the official description above is the record.
