# CVE-2020-24914: qcubed PHP object injection

> Unauthenticated attackers can execute arbitrary code by sending crafted POST requests to profile.php due to unsafe deserialization of user input.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2021
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-7w3c-jgh7-cwjw

## What is CVE-2020-24914?

CVE-2020-24914 is a critical unsafe deserialization vulnerability in n/a, published on 4 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A PHP object injection bug in profile.php in qcubed (all versions including 3.1.1) unserializes the untrusted data of the POST-variable "strProfileData" and allows an unauthenticated attacker to execute code via a crafted POST request.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-24914?

2 open source packages ship an affected version, including qcubed/qcubed. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qcubed/qcubed` | Packagist | All versions | 3.2 |
| `qcubed/qcubed` | Packagist | All versions | 3.2 |

Products: Qcubed Qcubed.

## How do I fix CVE-2020-24914?

Upgrade qcubed/qcubed to 3.2 or later.

## Is CVE-2020-24914 being exploited?

There is no known exploitation of CVE-2020-24914 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-24913](https://insights.sbomify.com/CVE-2020-24913/): qcubed SQL injection vulnerability in profile.php via the strQuery parameter (critical 9.8)
- [CVE-2020-24912](https://insights.sbomify.com/CVE-2020-24912/): qcubed reflected cross-site scripting (XSS) vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24914 and fix it if it is affected.

What it is: CVE-2020-24914 is a critical unsafe deserialization vulnerability in n/a, published on 4 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-24914 in the wild and no public exploit code.

Affected packages and fixed versions:
- qcubed/qcubed (Packagist): affected all versions; fixed in 3.2
- qcubed/qcubed (Packagist): affected all versions; fixed in 3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24914/ (Markdown: https://insights.sbomify.com/CVE-2020-24914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24914
- OSV: https://osv.dev/vulnerability/CVE-2020-24914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24914/
Summaries are generated and may contain mistakes; the official description above is the record.
