# CVE-2020-24939: Prototype pollution in supermixer

> Prototype pollution in Stampit supermixer allows attackers to modify object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-7prf-vw4p-qr59

## What is CVE-2020-24939?

CVE-2020-24939 is a high-severity vulnerability in n/a, published on 16 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Prototype pollution in Stampit supermixer 1.0.3 allows an attacker to modify the prototype of a base object which can vary in severity depending on the implementation.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2020-24939?

2 open source packages ship an affected version, including supermixer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `supermixer` | npm | All versions | 1.0.5 |
| `supermixer` | npm | All versions | 1.0.5 |

Products: Stampit Supermixer.

## How do I fix CVE-2020-24939?

Upgrade supermixer to 1.0.5 or later.

## Is CVE-2020-24939 being exploited?

There is no known exploitation of CVE-2020-24939 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24939 and fix it if it is affected.

What it is: CVE-2020-24939 is a high-severity vulnerability in n/a, published on 16 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-24939 in the wild and no public exploit code.

Affected packages and fixed versions:
- supermixer (npm): affected all versions; fixed in 1.0.5
- supermixer (npm): affected all versions; fixed in 1.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24939/ (Markdown: https://insights.sbomify.com/CVE-2020-24939/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24939
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24939
- OSV: https://osv.dev/vulnerability/CVE-2020-24939

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24939/
Summaries are generated and may contain mistakes; the official description above is the record.
