CVE-2020-24940 Guard bypass in Eloquent models affecting Laravel illuminate database component
Attackers can modify database records by exploiting unvalidated values during mass assignment when table names are stripped.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-24940?
CVE-2020-24940 is a high-severity vulnerability in n/a, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Laravel before 6.18.34 and 7.x before 7.23.2. Unvalidated values are saved to the database in some situations in which table names are stripped during a mass assignment.
Weakness: CWE-20
Which versions are affected by CVE-2020-24940?
7 open source packages ship an affected version, including illuminate/database and laravel. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
illuminate/database Packagist | From 5.5.0 to 5.5.44 | None |
illuminate/database Packagist | From 5.5.0 to 5.5.44 | None |
illuminate/database Packagist | From 6.0.0 | 6.18.34 |
illuminate/database Packagist | From 6.0.0 | 6.18.34 |
illuminate/database Packagist | From 7.0.0 | 7.23.2 |
illuminate/database Packagist | From 7.0.0 | 7.23.2 |
1 more packages
laravel Bitnami | All versions | 6.18.34, 7.23.2 |
Products include Laravel Laravel.
How do I fix CVE-2020-24940?
Upgrade illuminate/database to a fixed version for your release line: 6.18.34 or 7.23.2.
Is CVE-2020-24940 being exploited?
There is no known exploitation of CVE-2020-24940 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as BIT-laravel-2020-24940, GHSA-c7rm-w2hj-x8g3.