CVE-2020-24941 Improper Input Validation in Laravel
Attackers can bypass mass assignment protections in Laravel to modify protected model attributes via JSON column nesting expressions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-24941?
CVE-2020-24941 is a high-severity missing authorization vulnerability in n/a, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Laravel before 6.18.35 and 7.x before 7.24.0. The $guarded property is mishandled in some situations involving requests with JSON column nesting expressions.
Weakness: CWE-863
Which versions are affected by CVE-2020-24941?
5 open source packages ship an affected version, including laravel/framework and laravel. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
laravel/framework Packagist | All versions | 6.18.35 |
laravel/framework Packagist | All versions | 6.18.35 |
laravel/framework Packagist | From 7.0.0 | 7.24.0 |
laravel/framework Packagist | From 7.0.0 | 7.24.0 |
laravel Bitnami | All versions | 6.18.35, 7.24.0 |
Products include Laravel Laravel.
How do I fix CVE-2020-24941?
Upgrade laravel/framework to a fixed version for your release line: 6.18.35 or 7.24.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2020-24941 being exploited?
There is no known exploitation of CVE-2020-24941 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as BIT-laravel-2020-24941, GHSA-w68r-5p45-5rqp.