# CVE-2020-24941: Improper Input Validation in Laravel

> Attackers can bypass mass assignment protections in Laravel to modify protected model attributes via JSON column nesting expressions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-laravel-2020-24941, GHSA-w68r-5p45-5rqp

## What is CVE-2020-24941?

CVE-2020-24941 is a high-severity missing authorization vulnerability in n/a, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Laravel before 6.18.35 and 7.x before 7.24.0. The $guarded property is mishandled in some situations involving requests with JSON column nesting expressions.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-24941?

5 open source packages ship an affected version, including laravel/framework and laravel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laravel/framework` | Packagist | All versions | 6.18.35 |
| `laravel/framework` | Packagist | All versions | 6.18.35 |
| `laravel/framework` | Packagist | From 7.0.0 | 7.24.0 |
| `laravel/framework` | Packagist | From 7.0.0 | 7.24.0 |
| `laravel` | Bitnami | All versions | 6.18.35, 7.24.0 |

Products: Laravel Laravel.

## How do I fix CVE-2020-24941?

Upgrade laravel/framework to a fixed version for your release line: 6.18.35 or 7.24.0.

## Is CVE-2020-24941 being exploited?

There is no known exploitation of CVE-2020-24941 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-15133](https://insights.sbomify.com/CVE-2018-15133/): Laravel Deserialization of Untrusted Data (high 8.1, exploited in the wild)
- [CVE-2021-28254](https://insights.sbomify.com/CVE-2021-28254/): Deserialization in n/a (critical 9.8)
- [CVE-2020-24940](https://insights.sbomify.com/CVE-2020-24940/): Guard bypass in Eloquent models affecting Laravel illuminate database component (high 7.5)
- [CVE-2017-16894](https://insights.sbomify.com/CVE-2017-16894/): Information disclosure in n/a (high 7.5)
- [CVE-2021-21263](https://insights.sbomify.com/CVE-2021-21263/): Query Binding Exploitation in Laravel (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-24941 and fix it if it is affected.

What it is: CVE-2020-24941 is a high-severity missing authorization vulnerability in n/a, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-24941 in the wild and no public exploit code.

Affected packages and fixed versions:
- laravel/framework (Packagist): affected all versions; fixed in 6.18.35
- laravel/framework (Packagist): affected all versions; fixed in 6.18.35
- laravel/framework (Packagist): affected from 7.0.0; fixed in 7.24.0
- laravel/framework (Packagist): affected from 7.0.0; fixed in 7.24.0
- laravel (Bitnami): affected all versions; fixed in 6.18.35, 7.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-24941/ (Markdown: https://insights.sbomify.com/CVE-2020-24941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-24941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-24941
- OSV: https://osv.dev/vulnerability/CVE-2020-24941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-24941/
Summaries are generated and may contain mistakes; the official description above is the record.
