{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2020-24972 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-24972 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 29 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-24972 and fix it if it is affected.\n\nWhat it is: CVE-2020-24972 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 29 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-24972 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-24972/ (Markdown: https://insights.sbomify.com/CVE-2020-24972/index.md)","id":"CVE-2020-24972","markdown":"https://insights.sbomify.com/CVE-2020-24972/index.md","name":"CVE-2020-24972","record":{"aliases":["DEBIAN-CVE-2020-24972","GHSA-p3w5-fpg6-wrh9","MGASA-2020-0425","UBUNTU-CVE-2020-24972","openSUSE-SU-2020:1723-1","openSUSE-SU-2020:1754-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GnuPG Kleopatra","requires_auth":"none","summary":"Remote attackers can execute arbitrary code in Kleopatra by exploiting unsafe handling of openpgp4fpr URLs and Qt command-line options.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"kleopatra","vendor":"kleopatra_project"},{"product":"backports_sle","vendor":"opensuse"},{"product":"leap","vendor":"opensuse"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:N/S:U/UI:R","version":"3.1"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"The Kleopatra component before 3.1.12 (and before 20.07.80) for GnuPG allows remote attackers to execute arbitrary code because openpgp4fpr: URLs are supported without safe handling of command-line options. The Qt platformpluginpath command-line option can be used to load an arbitrary DLL.","ecosystems":["SUSE:Package Hub 15 SP1","openSUSE:Leap 15.1"],"exploits":{"exploitdb":0,"first_seen":"2024-09-01","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-09-01T13:13:58Z","kind":"github_poc","ref":"https://github.com/SpiralBL0CK/CVE-2020-24972","stars":1,"title":"PoC for CVE-2020-24972"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Command injection in n/a","id":"CVE-2020-24972","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:backports_sle","opensuse:leap"],"type":"command_injection","year":"2020"},"n_packages":2,"n_references":6,"next":{"headline":"Memory corruption in n/a","id":"CVE-2020-24977"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP1","fixed":["18.12.3-bp151.3.3.1"],"introduced":["0"],"last_affected":[],"package":"kleopatra","purl":"pkg:rpm/suse/kleopatra\u0026distro=SUSE%20Package%20Hub%2015%20SP1","source":"openSUSE-SU-2020:1754-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["18.12.3-lp151.2.4.1"],"introduced":["0"],"last_affected":[],"package":"kleopatra","purl":"pkg:rpm/opensuse/kleopatra\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2020:1723-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-24963"},"products":["n/a"],"published":"2020-08-29","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code in Kleopatra by exploiting unsafe handling of openpgp4fpr URLs and Qt command-line options.","url":"https://insights.sbomify.com/CVE-2020-24972/"}