{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-24994 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-24994 is a high-severity memory corruption vulnerability in n/a, published on 23 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-24994 and fix it if it is affected.\n\nWhat it is: CVE-2020-24994 is a high-severity memory corruption vulnerability in n/a, published on 23 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-24994 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-24994/ (Markdown: https://insights.sbomify.com/CVE-2020-24994/index.md)","id":"CVE-2020-24994","markdown":"https://insights.sbomify.com/CVE-2020-24994/index.md","name":"CVE-2020-24994","record":{"aliases":["DEBIAN-CVE-2020-24994","GHSA-qrhf-wgfc-f8cx","JLSEC-2026-154","SUSE-SU-2021:1664-1","UBUNTU-CVE-2020-24994","openSUSE-SU-2021:0773-1","openSUSE-SU-2021:1664-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"libass subtitle library","requires_auth":"none","summary":"Remote attackers can cause denial of service or execute code via a crafted file due to stack overflow in libass.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libass","vendor":"libass_project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Stack overflow in the parse_tag function in libass/ass_parse.c in libass before 0.15.0 allows remote attackers to cause a denial of service or remote code execution via a crafted file.","ecosystems":["SUSE:Linux Enterprise Module for Desktop Applications 15 SP2","SUSE:Linux Enterprise Module for Desktop Applications 15 SP3","openSUSE:Leap 15.2","openSUSE:Leap 15.3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2020-24994","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2020"},"n_packages":4,"n_references":4,"next":{"headline":"Memory corruption in n/a","id":"CVE-2020-24995"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP2","fixed":["0.14.0-3.6.1"],"introduced":["0"],"last_affected":[],"package":"libass","purl":"pkg:rpm/suse/libass\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP2","source":"SUSE-SU-2021:1664-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP3","fixed":["0.14.0-3.6.1"],"introduced":["0"],"last_affected":[],"package":"libass","purl":"pkg:rpm/suse/libass\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP3","source":"SUSE-SU-2021:1664-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["0.14.0-lp152.4.6.1"],"introduced":["0"],"last_affected":[],"package":"libass","purl":"pkg:rpm/opensuse/libass\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2021:0773-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["0.14.0-3.6.1"],"introduced":["0"],"last_affected":[],"package":"libass","purl":"pkg:rpm/opensuse/libass\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2021:1664-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-24993"},"products":["n/a"],"published":"2021-03-23","related":[{"cvss_score":8.8,"headline":"Integer overflow in n/a","id":"CVE-2020-26682","kev_date_added":null,"published":"2020-10-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service or execute code via a crafted file due to stack overflow in libass.","url":"https://insights.sbomify.com/CVE-2020-24994/"}