CVE-2020-25017 Other in n/a

High 8.3 Published Updated

Envoy proxy fails to replace all header values, potentially allowing attackers to bypass security controls relying on header inspection.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-25017?

CVE-2020-25017 is a high-severity vulnerability in Envoyproxy Envoy, published on 1 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Envoy through 1.15.0 only considers the first value when multiple header values are present for some HTTP headers. Envoy’s setCopy() header map API does not replace all existing occurences of a non-inline header.

Which versions are affected by CVE-2020-25017?

1 open source package ship an affected version, including envoy. It affects 1 product.

PackageAffectedFixed in
envoy BitnamiAll versions1.12.7, 1.13.4, 1.14.4, 1.15.1
Linux distribution packages (1)
servicemesh-proxy Red Hat:service_mesh:1.1::el8All versions0:1.1.9-1.el8

Products include Envoyproxy Envoy.

How do I fix CVE-2020-25017?

Upgrade envoy to a fixed version for your release line: 1.12.7, 1.13.4, 1.14.4 or 1.15.1.

Is CVE-2020-25017 being exploited?

There is no known exploitation of CVE-2020-25017 in the wild and no public exploit code.

All Envoyproxy Envoy vulnerabilities

Sources

Also known as BIT-envoy-2020-25017, GHSA-2v25-cjjq-5f4w, RHSA-2020:4129.

Is CVE-2020-25017 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free