# CVE-2020-25032: Flask-Cors Directory Traversal vulnerability

> Attackers can use directory traversal to access private resources in applications using the Flask-CORS library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-25032, DSA-4775-1, GHSA-xc3p-ff3m-f46v, PYSEC-2020-43, UBUNTU-CVE-2020-25032, USN-6019-1, openSUSE-SU-2020:1393-1, openSUSE-SU-2020:1415-1, openSUSE-SU-2020:1423-1, openSUSE-SU-2020:1446-1, openSUSE-SU-2024:11206-1, openSUSE-SU-2024:14129-1

## What is CVE-2020-25032?

CVE-2020-25032 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 31 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Flask-CORS (aka CORS Middleware for Flask) before 3.0.9. It allows ../ directory traversal to access private resources because resource matching does not ensure that pathnames are in a canonical format.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-25032?

3 open source packages ship an affected version, including flask-cors and Flask-Cors. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-cors` | PyPI | All versions | 3.0.9 |
| `flask-cors` | PyPI | All versions | 3.0.9 |
| `Flask-Cors` | PyPI | All versions | 3.0.9 |
| `python-Flask-Cors` | SUSE:Package Hub 15 SP1 | All versions | 3.0.7-bp151.2.3.1 |
| `python-Flask-Cors` | SUSE:Package Hub 15 SP2 | All versions | 3.0.8-bp152.2.3.1 |
| `python-Flask-Cors` | SUSE:Package Hub 15 SP2 | All versions | 3.0.8-bp152.2.3.1 |
| `python-Flask-Cors` | openSUSE:Leap 15.1 | All versions | 3.0.8-lp152.2.3.1 |
| `python-Flask-Cors` | openSUSE:Leap 15.2 | All versions | 3.0.8-lp152.2.3.1 |
| `python-Flask-Cors` | openSUSE:Tumbleweed | All versions | 3.0.10-1.3 |
| `python-Flask-Cors` | openSUSE:Tumbleweed | All versions | 4.0.0-1.3 |

Products: Debian Debian Linux, Flask-Cors Project Flask-Cors, Opensuse Backports Sle, Opensuse Leap.

## How do I fix CVE-2020-25032?

Upgrade flask-cors to 3.0.9 or later.

## Is CVE-2020-25032 being exploited?

There is no known exploitation of CVE-2020-25032 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25032 and fix it if it is affected.

What it is: CVE-2020-25032 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 31 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-25032 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-cors (PyPI): affected all versions; fixed in 3.0.9
- flask-cors (PyPI): affected all versions; fixed in 3.0.9
- Flask-Cors (PyPI): affected all versions; fixed in 3.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25032/ (Markdown: https://insights.sbomify.com/CVE-2020-25032/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25032
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25032
- OSV: https://osv.dev/vulnerability/CVE-2020-25032

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25032/
Summaries are generated and may contain mistakes; the official description above is the record.
