# CVE-2020-25074: MoinMoin vulnerable to remote code execution via cache action

> An attacker with upload privileges can exploit a directory traversal flaw in the cache action to achieve remote code execution on the MoinMoin wiki server.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-52q8-877j-gghq, PYSEC-2020-67, UBUNTU-CVE-2020-25074

## What is CVE-2020-25074?

CVE-2020-25074 is a critical path traversal vulnerability in Debian Debian Linux, published on 10 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The cache action in action/cache.py in MoinMoin through 1.9.10 allows directory traversal through a crafted HTTP request. An attacker who can upload attachments to the wiki can use this to achieve remote code execution.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-25074?

3 open source packages ship an affected version, including moin. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | All versions | 1.9.11 |
| `moin` | PyPI | All versions | 1.9.11 |
| `moin` | PyPI | All versions | 1.9.11 |

Products: Debian Debian Linux, Moinmo Moinmoin.

## How do I fix CVE-2020-25074?

Upgrade moin to 1.9.11 or later.

## Is CVE-2020-25074 being exploited?

There is no known exploitation of CVE-2020-25074 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25074 and fix it if it is affected.

What it is: CVE-2020-25074 is a critical path traversal vulnerability in Debian Debian Linux, published on 10 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-25074 in the wild and no public exploit code.

Affected packages and fixed versions:
- moin (PyPI): affected all versions; fixed in 1.9.11
- moin (PyPI): affected all versions; fixed in 1.9.11
- moin (PyPI): affected all versions; fixed in 1.9.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25074/ (Markdown: https://insights.sbomify.com/CVE-2020-25074/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25074
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25074
- OSV: https://osv.dev/vulnerability/CVE-2020-25074

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25074/
Summaries are generated and may contain mistakes; the official description above is the record.
