CVE-2020-25613 WEBRick vulnerable to HTTP Request/Response Smuggling
An attacker can exploit insufficient header validation in Ruby's WEBrick server to bypass reverse proxies and perform HTTP request smuggling.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-25613?
CVE-2020-25613 is a high-severity vulnerability in Fedoraproject Fedora, published on 6 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.
Weakness: CWE-444
Which versions are affected by CVE-2020-25613?
8 open source packages ship an affected version, including webrick, ruby and ruby-min. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
webrick RubyGems | All versions | 1.4.4 |
webrick RubyGems | All versions | 1.4.4 |
webrick RubyGems | From 1.5.0 | 1.5.1 |
webrick RubyGems | From 1.5.0 | 1.5.1 |
webrick RubyGems | From 1.6.0 | 1.6.1 |
webrick RubyGems | From 1.6.0 | 1.6.1 |
2 more packages
ruby Bitnami | All versions | 2.5.9, 2.6.7, 2.7.2 |
ruby-min Bitnami | All versions | 2.5.9, 2.6.7, 2.7.2 |
Linux distribution packages (16)
ruby2.5 SUSE:Enterprise Storage 6 | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Linux Enterprise Micro 5.0 | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Linux Enterprise Server 15-LTSS | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Manager Proxy 4.0 | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Manager Retail Branch Server 4.0 | All versions | 2.5.8-4.14.1 |
ruby2.5 SUSE:Manager Server 4.0 | All versions | 2.5.8-4.14.1 |
ruby2.5 openSUSE:Leap 15.2 | All versions | 2.5.8-lp152.2.3.1 |
Products include Fedoraproject Fedora, Ruby-Lang Ruby, Ruby-Lang Webrick.
How do I fix CVE-2020-25613?
Upgrade webrick to a fixed version for your release line: 1.4.4, 1.5.1 or 1.6.1.
Is CVE-2020-25613 being exploited?
There is no known exploitation of CVE-2020-25613 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALPINE-CVE-2020-25613, BIT-ruby-2020-25613, BIT-ruby-min-2020-25613, CLEANSTART-2026-PR43323, DEBIAN-CVE-2020-25613, DLA-2391-1 and 7 more.