# CVE-2020-25613: WEBRick vulnerable to HTTP Request/Response Smuggling

> An attacker can exploit insufficient header validation in Ruby's WEBrick server to bypass reverse proxies and perform HTTP request smuggling.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-25613, BIT-ruby-2020-25613, BIT-ruby-min-2020-25613, CLEANSTART-2026-PR43323, DEBIAN-CVE-2020-25613, DLA-2391-1, DLA-2392-1, GHSA-gwfg-cqmg-cf8f, JLSEC-2026-1281, MGASA-2020-0423, SUSE-SU-2021:0933-1, UBUNTU-CVE-2020-25613, openSUSE-SU-2021:0471-1

## What is CVE-2020-25613?

CVE-2020-25613 is a high-severity vulnerability in Fedoraproject Fedora, published on 6 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2020-25613?

8 open source packages ship an affected version, including webrick, ruby and ruby-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webrick` | RubyGems | All versions | 1.4.4 |
| `webrick` | RubyGems | All versions | 1.4.4 |
| `webrick` | RubyGems | From 1.5.0 | 1.5.1 |
| `webrick` | RubyGems | From 1.5.0 | 1.5.1 |
| `webrick` | RubyGems | From 1.6.0 | 1.6.1 |
| `webrick` | RubyGems | From 1.6.0 | 1.6.1 |
| `ruby` | Bitnami | All versions | 2.5.9, 2.6.7, 2.7.2 |
| `ruby-min` | Bitnami | All versions | 2.5.9, 2.6.7, 2.7.2 |
| `ruby2.5` | SUSE:Enterprise Storage 6 | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Linux Enterprise Micro 5.0 | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Linux Enterprise Server 15-LTSS | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Manager Proxy 4.0 | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Manager Retail Branch Server 4.0 | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | SUSE:Manager Server 4.0 | All versions | 2.5.8-4.14.1 |
| `ruby2.5` | openSUSE:Leap 15.2 | All versions | 2.5.8-lp152.2.3.1 |

Products: Fedoraproject Fedora, Ruby-Lang Ruby, Ruby-Lang Webrick.

## How do I fix CVE-2020-25613?

Upgrade webrick to a fixed version for your release line: 1.4.4, 1.5.1 or 1.6.1.

## Is CVE-2020-25613 being exploited?

There is no known exploitation of CVE-2020-25613 in the wild and no public exploit code.

Public exploit code:

- https://github.com/metapox/CVE-2020-25613 (github_poc): https://github.com/metapox/CVE-2020-25613

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25613 and fix it if it is affected.

What it is: CVE-2020-25613 is a high-severity vulnerability in Fedoraproject Fedora, published on 6 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-25613 in the wild and no public exploit code.

Affected packages and fixed versions:
- webrick (RubyGems): affected all versions; fixed in 1.4.4
- webrick (RubyGems): affected all versions; fixed in 1.4.4
- webrick (RubyGems): affected from 1.5.0; fixed in 1.5.1
- webrick (RubyGems): affected from 1.5.0; fixed in 1.5.1
- webrick (RubyGems): affected from 1.6.0; fixed in 1.6.1
- webrick (RubyGems): affected from 1.6.0; fixed in 1.6.1
- ruby (Bitnami): affected all versions; fixed in 2.5.9, 2.6.7, 2.7.2
- ruby-min (Bitnami): affected all versions; fixed in 2.5.9, 2.6.7, 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25613/ (Markdown: https://insights.sbomify.com/CVE-2020-25613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25613
- OSV: https://osv.dev/vulnerability/CVE-2020-25613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25613/
Summaries are generated and may contain mistakes; the official description above is the record.
