CVE-2020-25627 Moodle stored Cross-site Scripting (XSS)

Medium 6.1 Published Updated

Attackers can inject malicious scripts via user profile fields, potentially stealing sessions or executing code in victim browsers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-25627?

CVE-2020-25627 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 9 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The moodlenetprofile user profile field required extra sanitizing to prevent a stored XSS risk. This affects versions 3.9 to 3.9.1. Fixed in 3.9.2.

Weakness: CWE-79

Which versions are affected by CVE-2020-25627?

3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 3.93.9.2
moodle/moodle PackagistFrom 3.93.9.2
moodle BitnamiFrom 3.9.03.9.2

Products include Moodle Moodle.

How do I fix CVE-2020-25627?

Upgrade moodle/moodle to 3.9.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-25627 being exploited?

There is no known exploitation of CVE-2020-25627 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Moodle Moodle vulnerabilities

Sources

Also known as BIT-moodle-2020-25627, GHSA-mgfp-qcf2-pw3m, UBUNTU-CVE-2020-25627.

Is CVE-2020-25627 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free