CVE-2020-25629 Moodle incorrect access control
Course managers can escalate privileges to site administration by logging in as a System manager, requiring an upgrade to patched Moodle versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-25629?
CVE-2020-25629 is a high-severity vulnerability in Moodle Moodle, published on 8 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Which versions are affected by CVE-2020-25629?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.5 | 3.5.14 |
moodle/moodle Packagist | From 3.5 | 3.5.14 |
moodle/moodle Packagist | From 3.7 | 3.7.8 |
moodle/moodle Packagist | From 3.7 | 3.7.8 |
moodle/moodle Packagist | From 3.8 | 3.8.5 |
moodle/moodle Packagist | From 3.8 | 3.8.5 |
3 more packages
moodle/moodle Packagist | From 3.9 | 3.9.2 |
moodle/moodle Packagist | From 3.9 | 3.9.2 |
moodle Bitnami | From 3.5.0 | 3.5.14, 3.7.8, 3.8.5, 3.9.2 |
Products include Moodle Moodle.
How do I fix CVE-2020-25629?
Upgrade moodle/moodle to a fixed version for your release line: 3.5.14, 3.7.8, 3.8.5 or 3.9.2.
Is CVE-2020-25629 being exploited?
There is no known exploitation of CVE-2020-25629 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2020-25629, GHSA-f5r8-7h4f-jr9x, UBUNTU-CVE-2020-25629.