CVE-2020-25630 Moodle Denial of Service
Attackers can cause denial of service in Moodle by uploading zip files that exceed user quotas, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-25630?
CVE-2020-25630 is a high-severity denial of service vulnerability in Moodle Moodle, published on 8 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Weakness: CWE-400
Which versions are affected by CVE-2020-25630?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.5 | 3.5.14 |
moodle/moodle Packagist | From 3.5 | 3.5.14 |
moodle/moodle Packagist | From 3.7 | 3.7.8 |
moodle/moodle Packagist | From 3.7 | 3.7.8 |
moodle/moodle Packagist | From 3.8 | 3.8.5 |
moodle/moodle Packagist | From 3.8 | 3.8.5 |
3 more packages
moodle/moodle Packagist | From 3.9 | 3.9.2 |
moodle/moodle Packagist | From 3.9 | 3.9.2 |
moodle Bitnami | From 3.5.0 | 3.5.14, 3.7.8, 3.8.5, 3.9.2 |
Products include Moodle Moodle.
How do I fix CVE-2020-25630?
Upgrade moodle/moodle to a fixed version for your release line: 3.5.14, 3.7.8, 3.8.5 or 3.9.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-25630 being exploited?
There is no known exploitation of CVE-2020-25630 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2020-25630, GHSA-66xp-28cq-mrf2, UBUNTU-CVE-2020-25630.