{"answers":{"affected":"9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-25630 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.5.14, 3.7.8, 3.8.5 or 3.9.2.","what":"CVE-2020-25630 is a high-severity denial of service vulnerability in Moodle Moodle, published on 8 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-25630 and fix it if it is affected.\n\nWhat it is: CVE-2020-25630 is a high-severity denial of service vulnerability in Moodle Moodle, published on 8 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-25630 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.14\n- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.14\n- moodle/moodle (Packagist): affected from 3.7; fixed in 3.7.8\n- moodle/moodle (Packagist): affected from 3.7; fixed in 3.7.8\n- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.5\n- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.5\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.2\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.2\n- moodle (Bitnami): affected from 3.5.0; fixed in 3.5.14, 3.7.8, 3.8.5, 3.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-25630/ (Markdown: https://insights.sbomify.com/CVE-2020-25630/index.md)","id":"CVE-2020-25630","markdown":"https://insights.sbomify.com/CVE-2020-25630/index.md","name":"CVE-2020-25630","record":{"aliases":["BIT-moodle-2020-25630","GHSA-66xp-28cq-mrf2","UBUNTU-CVE-2020-25630"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Attackers can cause denial of service in Moodle by uploading zip files that exceed user quotas, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle Denial of Service","id":"CVE-2020-25630","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"denial_of_service","year":"2020"},"n_packages":9,"n_references":1,"next":{"headline":"Moodle Cross-site Scripting (XSS)","id":"CVE-2020-25631"},"packages":[{"ecosystem":"Bitnami","fixed":["3.5.14","3.7.8","3.8.5","3.9.2"],"introduced":["3.5.0","3.7.0","3.8.0","3.9.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2020-25630"},{"ecosystem":"Packagist","fixed":["3.5.14"],"introduced":["3.5"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-66xp-28cq-mrf2"},{"ecosystem":"Packagist","fixed":["3.5.14"],"introduced":["3.5"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-66xp-28cq-mrf2"},{"ecosystem":"Packagist","fixed":["3.7.8"],"introduced":["3.7"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-66xp-28cq-mrf2"},{"ecosystem":"Packagist","fixed":["3.7.8"],"introduced":["3.7"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-66xp-28cq-mrf2"},{"ecosystem":"Packagist","fixed":["3.8.5"],"introduced":["3.8"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-66xp-28cq-mrf2"},{"ecosystem":"Packagist","fixed":["3.8.5"],"introduced":["3.8"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-66xp-28cq-mrf2"},{"ecosystem":"Packagist","fixed":["3.9.2"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-66xp-28cq-mrf2"},{"ecosystem":"Packagist","fixed":["3.9.2"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-66xp-28cq-mrf2"}],"prev":{"headline":"Moodle incorrect access control","id":"CVE-2020-25629"},"products":["Moodle"],"published":"2020-12-08","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can cause denial of service in Moodle by uploading zip files that exceed user quotas, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2020-25630/"}