# CVE-2020-25630: Moodle Denial of Service

> Attackers can cause denial of service in Moodle by uploading zip files that exceed user quotas, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-moodle-2020-25630, GHSA-66xp-28cq-mrf2, UBUNTU-CVE-2020-25630

## What is CVE-2020-25630?

CVE-2020-25630 is a high-severity denial of service vulnerability in Moodle Moodle, published on 8 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2020-25630?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.14 |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.14 |
| `moodle/moodle` | Packagist | From 3.7 | 3.7.8 |
| `moodle/moodle` | Packagist | From 3.7 | 3.7.8 |
| `moodle/moodle` | Packagist | From 3.8 | 3.8.5 |
| `moodle/moodle` | Packagist | From 3.8 | 3.8.5 |
| `moodle/moodle` | Packagist | From 3.9 | 3.9.2 |
| `moodle/moodle` | Packagist | From 3.9 | 3.9.2 |
| `moodle` | Bitnami | From 3.5.0 | 3.5.14, 3.7.8, 3.8.5, 3.9.2 |

Products: Moodle Moodle.

## How do I fix CVE-2020-25630?

Upgrade moodle/moodle to a fixed version for your release line: 3.5.14, 3.7.8, 3.8.5 or 3.9.2.

## Is CVE-2020-25630 being exploited?

There is no known exploitation of CVE-2020-25630 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25630 and fix it if it is affected.

What it is: CVE-2020-25630 is a high-severity denial of service vulnerability in Moodle Moodle, published on 8 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-25630 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.14
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.14
- moodle/moodle (Packagist): affected from 3.7; fixed in 3.7.8
- moodle/moodle (Packagist): affected from 3.7; fixed in 3.7.8
- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.5
- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.5
- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.2
- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.2
- moodle (Bitnami): affected from 3.5.0; fixed in 3.5.14, 3.7.8, 3.8.5, 3.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25630/ (Markdown: https://insights.sbomify.com/CVE-2020-25630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25630
- OSV: https://osv.dev/vulnerability/CVE-2020-25630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25630/
Summaries are generated and may contain mistakes; the official description above is the record.
