# CVE-2020-25635: Ansible does not collect garbage after playbook run

> Ansible AWS SSM plugin fails to clean up temporary files, potentially exposing sensitive data in storage buckets.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-f556-49jc-4rvc, PYSEC-2020-220, UBUNTU-CVE-2020-25635

## What is CVE-2020-25635?

CVE-2020-25635 is a medium-severity vulnerability in AWS Community Community Collections, published on 5 Oct 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Ansible Base when using the aws_ssm connection plugin as garbage collector is not happening after playbook run is completed. Files would remain in the bucket exposing the data. This issue affects directly data confidentiality.

Weakness: CWE-212 (Improper Removal of Sensitive Information Before Storage or Transfer)

## Which versions are affected by CVE-2020-25635?

3 open source packages ship an affected version, including ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.10.1 |
| `ansible` | PyPI | All versions | 2.10.1 |
| `ansible` | PyPI | All versions | 2.10.1 |

Products: Redhat Ansible.

## How do I fix CVE-2020-25635?

Upgrade ansible to 2.10.1 or later.

## Is CVE-2020-25635 being exploited?

There is no known exploitation of CVE-2020-25635 in the wild and no public exploit code.

## Other vulnerabilities in AWS Community Community Collections

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25635 and fix it if it is affected.

What it is: CVE-2020-25635 is a medium-severity vulnerability in AWS Community Community Collections, published on 5 Oct 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-25635 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.10.1
- ansible (PyPI): affected all versions; fixed in 2.10.1
- ansible (PyPI): affected all versions; fixed in 2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25635/ (Markdown: https://insights.sbomify.com/CVE-2020-25635/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25635
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25635
- OSV: https://osv.dev/vulnerability/CVE-2020-25635

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25635/
Summaries are generated and may contain mistakes; the official description above is the record.
