# CVE-2020-25640: Wildfly logs plaintext passwords

> Attackers can read plain text JMS passwords from log files when connection errors occur in WildFly application servers.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-wildfly-2020-25640, GHSA-jw3v-5ch2-wfmm

## What is CVE-2020-25640?

CVE-2020-25640 is a medium-severity vulnerability in wildfly, published on 24 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was discovered in WildFly before 21.0.0.Final where, Resource adapter logs plain text JMS password at warning level on connection error, inserting sensitive information in the log file.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2020-25640?

3 open source packages ship an affected version, including org.wildfly:wildfly-parent and wildfly. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wildfly:wildfly-parent` | Maven | All versions | 21.0.0.Final |
| `org.wildfly:wildfly-parent` | Maven | All versions | 21.0.0.Final |
| `wildfly` | Bitnami | All versions | 21.0.0 |

Products: Redhat Wildfly.

## How do I fix CVE-2020-25640?

Upgrade org.wildfly:wildfly-parent to 21.0.0.Final or later.

## Is CVE-2020-25640 being exploited?

There is no known exploitation of CVE-2020-25640 in the wild and no public exploit code.

## Other vulnerabilities in wildfly

- [CVE-2018-10683](https://insights.sbomify.com/CVE-2018-10683/): Auth bypass in n/a (critical 9.8)
- [CVE-2020-10740](https://insights.sbomify.com/CVE-2020-10740/): Wildfly Unsafe Deserialization Vulnerability (medium 6.6)
- [CVE-2020-27822](https://insights.sbomify.com/CVE-2020-27822/): Wildfly has a memory leak vulnerability (medium 5.9)
- [CVE-2020-1719](https://insights.sbomify.com/CVE-2020-1719/): Privilege Context Switching Error in wildlfy (medium 5.4)
- [CVE-2018-14627](https://insights.sbomify.com/CVE-2018-14627/): Security feature bypass in JBoss/WildFly (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25640 and fix it if it is affected.

What it is: CVE-2020-25640 is a medium-severity vulnerability in wildfly, published on 24 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-25640 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wildfly:wildfly-parent (Maven): affected all versions; fixed in 21.0.0.Final
- org.wildfly:wildfly-parent (Maven): affected all versions; fixed in 21.0.0.Final
- wildfly (Bitnami): affected all versions; fixed in 21.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25640/ (Markdown: https://insights.sbomify.com/CVE-2020-25640/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25640
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25640
- OSV: https://osv.dev/vulnerability/CVE-2020-25640

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25640/
Summaries are generated and may contain mistakes; the official description above is the record.
