# CVE-2020-25658: Timing attacks in python-rsa

> An attacker can exploit timing side-channels in the RSA decryption API to partially decrypt ciphertext, compromising data confidentiality.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-25658, ECHO-28ab-14a8-957a, GHSA-xrx6-fmxq-rjj2, MGASA-2021-0456, PYSEC-2020-100, SUSE-SU-2022:3932-1, SUSE-SU-2023:0648-1, UBUNTU-CVE-2020-25658

## What is CVE-2020-25658?

CVE-2020-25658 is a high-severity vulnerability in Fedoraproject Fedora, published on 12 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

It was found that python-rsa is vulnerable to Bleichenbacher timing attacks. An attacker can use this flaw via the RSA decryption API to decrypt parts of the cipher text encrypted with RSA.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm), CWE-385 (Covert Timing Channel)

## Which versions are affected by CVE-2020-25658?

3 open source packages ship an affected version, including rsa. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rsa` | PyPI | From 2.1 | 4.7 |
| `rsa` | PyPI | From 2.1 | 4.7 |
| `rsa` | PyPI | From 2.1 | 4.7 |
| `python-rsa` | SUSE:Linux Enterprise Micro 5.2 | All versions | 3.4.2-150000.3.7.1 |
| `python-rsa` | SUSE:Linux Enterprise Micro 5.3 | All versions | 3.4.2-150000.3.7.1 |
| `python-rsa` | SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 3.4.2-150000.3.7.1 |
| `python-rsa` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 3.4.2-150000.3.7.1 |
| `python-rsa` | SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 3.4.2-150000.3.7.1 |
| `python-rsa` | SUSE:Linux Enterprise Module for Package Hub 15 SP4 | All versions | 3.4.2-150000.3.7.1 |
| `python-rsa` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 3.1.4-12.19.2 |
| `python-rsa` | openSUSE:Leap 15.3 | All versions | 3.4.2-150000.3.7.1 |
| `python-rsa` | openSUSE:Leap 15.4 | All versions | 3.4.2-150000.3.7.1 |
| `python-rsa` | openSUSE:Leap Micro 5.2 | All versions | 3.4.2-150000.3.7.1 |

Products: Fedoraproject Fedora, Python-Rsa Project Python-Rsa, Redhat Openstack Platform.

## How do I fix CVE-2020-25658?

Upgrade rsa to 4.7 or later.

## Is CVE-2020-25658 being exploited?

There is no known exploitation of CVE-2020-25658 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25658 and fix it if it is affected.

What it is: CVE-2020-25658 is a high-severity vulnerability in Fedoraproject Fedora, published on 12 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-25658 in the wild and no public exploit code.

Affected packages and fixed versions:
- rsa (PyPI): affected from 2.1; fixed in 4.7
- rsa (PyPI): affected from 2.1; fixed in 4.7
- rsa (PyPI): affected from 2.1; fixed in 4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25658/ (Markdown: https://insights.sbomify.com/CVE-2020-25658/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25658
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25658
- OSV: https://osv.dev/vulnerability/CVE-2020-25658

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25658/
Summaries are generated and may contain mistakes; the official description above is the record.
