{"answers":{"affected":"2 open source packages ship an affected version, including postgresql and org.postgresql:postgresql. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-25694 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 9.5.24, 9.6.20, 10.15.0 or 11.10.0.","what":"CVE-2020-25694 is a high-severity vulnerability in Debian Debian Linux, published on 16 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-25694 and fix it if it is affected.\n\nWhat it is: CVE-2020-25694 is a high-severity vulnerability in Debian Debian Linux, published on 16 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-25694 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected all versions; fixed in 9.5.24, 9.6.20, 10.15.0, 11.10.0, 12.5.0, 13.1.0\n- org.postgresql:postgresql (Maven): affected all versions; fixed in 13.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-25694/ (Markdown: https://insights.sbomify.com/CVE-2020-25694/index.md)","id":"CVE-2020-25694","markdown":"https://insights.sbomify.com/CVE-2020-25694/index.md","name":"CVE-2020-25694","record":{"aliases":["ALPINE-CVE-2020-25694","BIT-postgresql-2020-25694","CLEANSTART-2026-OY05892","DEBIAN-CVE-2020-25694","ECHO-814d-438f-9a88","GHSA-vmm8-82m2-pcp5","JLSEC-2026-26","UBUNTU-CVE-2020-25694"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL database","requires_auth":"none","summary":"Man-in-the-middle attackers can observe or modify clear-text transmissions if client applications drop security parameters during connection reuse.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"}],"description":"A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If a client application that creates additional database connections only reuses the basic connection parameters while dropping security-relevant parameters, an opportunity for a man-in-the-middle attack, or the ability to observe clear-text transmissions, could exist. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use of a Broken or Risky Cryptographic Algorithm in PostgreSQL","id":"CVE-2020-25694","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","postgresql:postgresql"],"type":"weak_cryptography","year":"2020"},"n_packages":2,"n_references":5,"next":{"headline":"SQL Injection","id":"CVE-2020-25695"},"packages":[{"ecosystem":"Bitnami","fixed":["9.5.24","9.6.20","10.15.0","11.10.0","12.5.0","13.1.0"],"introduced":["0","9.6.0","10.0.0","11.0.0","12.0.0","13.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2020-25694"},{"ecosystem":"Maven","fixed":["13.1"],"introduced":["0"],"last_affected":[],"package":"org.postgresql:postgresql","purl":"pkg:maven/org.postgresql/postgresql","source":"GHSA-vmm8-82m2-pcp5"}],"prev":{"headline":"Integer overflow in CImg","id":"CVE-2020-25693"},"products":["postgresql"],"published":"2020-11-16","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can observe or modify clear-text transmissions if client applications drop security parameters during connection reuse.","url":"https://insights.sbomify.com/CVE-2020-25694/"}