# CVE-2020-25694: Use of a Broken or Risky Cryptographic Algorithm in PostgreSQL

> Man-in-the-middle attackers can observe or modify clear-text transmissions if client applications drop security parameters during connection reuse.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-25694, BIT-postgresql-2020-25694, CLEANSTART-2026-OY05892, DEBIAN-CVE-2020-25694, ECHO-814d-438f-9a88, GHSA-vmm8-82m2-pcp5, JLSEC-2026-26, UBUNTU-CVE-2020-25694

## What is CVE-2020-25694?

CVE-2020-25694 is a high-severity vulnerability in Debian Debian Linux, published on 16 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If a client application that creates additional database connections only reuses the basic connection parameters while dropping security-relevant parameters, an opportunity for a man-in-the-middle attack, or the ability to observe clear-text transmissions, could exist. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2020-25694?

2 open source packages ship an affected version, including postgresql and org.postgresql:postgresql. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 9.5.24, 9.6.20, 10.15.0, 11.10.0, 12.5.0, 13.1.0 |
| `org.postgresql:postgresql` | Maven | All versions | 13.1 |

Products: Debian Debian Linux, Postgresql Postgresql.

## How do I fix CVE-2020-25694?

Upgrade postgresql to a fixed version for your release line: 9.5.24, 9.6.20, 10.15.0 or 11.10.0.

## Is CVE-2020-25694 being exploited?

There is no known exploitation of CVE-2020-25694 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25694 and fix it if it is affected.

What it is: CVE-2020-25694 is a high-severity vulnerability in Debian Debian Linux, published on 16 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-25694 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 9.5.24, 9.6.20, 10.15.0, 11.10.0, 12.5.0, 13.1.0
- org.postgresql:postgresql (Maven): affected all versions; fixed in 13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25694/ (Markdown: https://insights.sbomify.com/CVE-2020-25694/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25694
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25694
- OSV: https://osv.dev/vulnerability/CVE-2020-25694

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25694/
Summaries are generated and may contain mistakes; the official description above is the record.
