{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-25696 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 9.5.24, 9.6.20, 10.15.0 or 11.10.0.","what":"CVE-2020-25696 is a high-severity code injection vulnerability in Debian Debian Linux, published on 23 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-25696 and fix it if it is affected.\n\nWhat it is: CVE-2020-25696 is a high-severity code injection vulnerability in Debian Debian Linux, published on 23 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-25696 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected from 9.5.0; fixed in 9.5.24, 9.6.20, 10.15.0, 11.10.0, 12.5.0, 13.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-25696/ (Markdown: https://insights.sbomify.com/CVE-2020-25696/index.md)","id":"CVE-2020-25696","markdown":"https://insights.sbomify.com/CVE-2020-25696/index.md","name":"CVE-2020-25696","record":{"aliases":["ALPINE-CVE-2020-25696","BIT-postgresql-2020-25696","CLEANSTART-2026-FL46674","DEBIAN-CVE-2020-25696","ECHO-29d7-c7c3-a6cc","GHSA-rfp5-6w27-jrq7","JLSEC-2026-28","UBUNTU-CVE-2020-25696"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL psql client","requires_auth":"none","summary":"Attackers can execute arbitrary code on the client machine via the psql interactive terminal when querying a compromised server using the \\gset command.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-697","name":"Incorrect Comparison"},{"id":"CWE-183","name":"Permissive List of Allowed Inputs"}],"description":"A flaw was found in the psql interactive terminal of PostgreSQL in versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If an interactive psql session uses \\gset when querying a compromised server, the attacker can execute arbitrary code as the operating system account running psql. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect Comparison, Permissive List of Allowed Inputs, and Privilege Context Switching Error in PostgreSQL","id":"CVE-2020-25696","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","postgresql:postgresql"],"type":"code_injection","year":"2020"},"n_packages":1,"n_references":4,"next":{"headline":"Auth bypass in xorg-x11-server","id":"CVE-2020-25697"},"packages":[{"ecosystem":"Bitnami","fixed":["9.5.24","9.6.20","10.15.0","11.10.0","12.5.0","13.1.0"],"introduced":["9.5.0","9.6.0","10.0.0","11.0.0","12.0.0","13.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2020-25696"}],"prev":{"headline":"SQL Injection","id":"CVE-2020-25695"},"products":["PostgreSQL"],"published":"2020-11-23","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code on the client machine via the psql interactive terminal when querying a compromised server using the \\gset command.","url":"https://insights.sbomify.com/CVE-2020-25696/"}