# CVE-2020-25696: Incorrect Comparison, Permissive List of Allowed Inputs, and Privilege Context Switching Error in PostgreSQL

> Attackers can execute arbitrary code on the client machine via the psql interactive terminal when querying a compromised server using the \gset command.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-25696, BIT-postgresql-2020-25696, CLEANSTART-2026-FL46674, DEBIAN-CVE-2020-25696, ECHO-29d7-c7c3-a6cc, GHSA-rfp5-6w27-jrq7, JLSEC-2026-28, UBUNTU-CVE-2020-25696

## What is CVE-2020-25696?

CVE-2020-25696 is a high-severity code injection vulnerability in Debian Debian Linux, published on 23 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in the psql interactive terminal of PostgreSQL in versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If an interactive psql session uses \gset when querying a compromised server, the attacker can execute arbitrary code as the operating system account running psql. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Weakness: CWE-697 (Incorrect Comparison), CWE-183 (Permissive List of Allowed Inputs)

## Which versions are affected by CVE-2020-25696?

1 open source package ship an affected version, including postgresql. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 9.5.0 | 9.5.24, 9.6.20, 10.15.0, 11.10.0, 12.5.0, 13.1.0 |

Products: Debian Debian Linux, Postgresql Postgresql.

## How do I fix CVE-2020-25696?

Upgrade postgresql to a fixed version for your release line: 9.5.24, 9.6.20, 10.15.0 or 11.10.0.

## Is CVE-2020-25696 being exploited?

There is no known exploitation of CVE-2020-25696 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25696 and fix it if it is affected.

What it is: CVE-2020-25696 is a high-severity code injection vulnerability in Debian Debian Linux, published on 23 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-25696 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 9.5.0; fixed in 9.5.24, 9.6.20, 10.15.0, 11.10.0, 12.5.0, 13.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25696/ (Markdown: https://insights.sbomify.com/CVE-2020-25696/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25696
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25696
- OSV: https://osv.dev/vulnerability/CVE-2020-25696

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25696/
Summaries are generated and may contain mistakes; the official description above is the record.
