CVE-2020-25698 Improper Access Control in moodle

High 7.5 Published Updated

Attackers can unenroll users from courses without permission due to insufficient capability checks during course restoration.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-25698?

CVE-2020-25698 is a high-severity missing authorization vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Weakness: CWE-284

Which versions are affected by CVE-2020-25698?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.

PackageAffectedFixed in
moodle/moodle PackagistFrom 3.53.5.15
moodle/moodle PackagistFrom 3.53.5.15
moodle/moodle PackagistFrom 3.7.03.7.9
moodle/moodle PackagistFrom 3.7.03.7.9
moodle/moodle PackagistFrom 3.8.03.8.6
moodle/moodle PackagistFrom 3.8.03.8.6
3 more packages
moodle/moodle PackagistFrom 3.9.03.9.3
moodle/moodle PackagistFrom 3.9.03.9.3
moodle BitnamiFrom 3.5.03.5.15, 3.7.9, 3.8.6, 3.9.3

Products include Fedoraproject Fedora, Moodle Moodle.

How do I fix CVE-2020-25698?

Upgrade moodle/moodle to a fixed version for your release line: 3.5.15, 3.7.9, 3.8.6 or 3.9.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2020-25698 being exploited?

There is no known exploitation of CVE-2020-25698 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as BIT-moodle-2020-25698, GHSA-vxhx-gmhm-623c, UBUNTU-CVE-2020-25698.

Is CVE-2020-25698 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free