{"answers":{"affected":"9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-25699 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.5.15, 3.7.9, 3.8.6 or 3.9.3.","what":"CVE-2020-25699 is a high-severity vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-25699 and fix it if it is affected.\n\nWhat it is: CVE-2020-25699 is a high-severity vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-25699 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.15\n- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.15\n- moodle/moodle (Packagist): affected from 3.7.0; fixed in 3.7.9\n- moodle/moodle (Packagist): affected from 3.7.0; fixed in 3.7.9\n- moodle/moodle (Packagist): affected from 3.8.0; fixed in 3.8.6\n- moodle/moodle (Packagist): affected from 3.8.0; fixed in 3.8.6\n- moodle/moodle (Packagist): affected from 3.9.0; fixed in 3.9.3\n- moodle/moodle (Packagist): affected from 3.9.0; fixed in 3.9.3\n- moodle (Bitnami): affected from 3.5.0; fixed in 3.5.15, 3.7.9, 3.8.6, 3.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-25699/ (Markdown: https://insights.sbomify.com/CVE-2020-25699/index.md)","id":"CVE-2020-25699","markdown":"https://insights.sbomify.com/CVE-2020-25699/index.md","name":"CVE-2020-25699","record":{"aliases":["BIT-moodle-2020-25699","GHSA-h77r-rp97-7rv4","UBUNTU-CVE-2020-25699"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Users with course restore permissions can improperly add capabilities to roles, leading to privilege escalation within Moodle courses.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"moodle","vendor":"moodle"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilage Escalation in moodle","id":"CVE-2020-25699","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","moodle:moodle"],"type":"privilege_escalation","year":"2020"},"n_packages":9,"n_references":4,"next":{"headline":"SQL Injection in moodle","id":"CVE-2020-25700"},"packages":[{"ecosystem":"Bitnami","fixed":["3.5.15","3.7.9","3.8.6","3.9.3"],"introduced":["3.5.0","3.7.0","3.8.0","3.9.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2020-25699"},{"ecosystem":"Packagist","fixed":["3.5.15"],"introduced":["3.5"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-h77r-rp97-7rv4"},{"ecosystem":"Packagist","fixed":["3.5.15"],"introduced":["3.5"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-h77r-rp97-7rv4"},{"ecosystem":"Packagist","fixed":["3.7.9"],"introduced":["3.7.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-h77r-rp97-7rv4"},{"ecosystem":"Packagist","fixed":["3.7.9"],"introduced":["3.7.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-h77r-rp97-7rv4"},{"ecosystem":"Packagist","fixed":["3.8.6"],"introduced":["3.8.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-h77r-rp97-7rv4"},{"ecosystem":"Packagist","fixed":["3.8.6"],"introduced":["3.8.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-h77r-rp97-7rv4"},{"ecosystem":"Packagist","fixed":["3.9.3"],"introduced":["3.9.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-h77r-rp97-7rv4"},{"ecosystem":"Packagist","fixed":["3.9.3"],"introduced":["3.9.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-h77r-rp97-7rv4"}],"prev":{"headline":"Improper Access Control in moodle","id":"CVE-2020-25698"},"products":["moodle"],"published":"2020-11-19","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Users with course restore permissions can improperly add capabilities to roles, leading to privilege escalation within Moodle courses.","url":"https://insights.sbomify.com/CVE-2020-25699/"}