CVE-2020-25701 Privilage Escalation in moodle
Attackers can gain unauthorized course access by exploiting a logic error in the upload tool that erroneously enables disabled enrollment methods.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-25701?
CVE-2020-25701 is a medium-severity vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
Which versions are affected by CVE-2020-25701?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.5 | 3.5.15 |
moodle/moodle Packagist | From 3.5 | 3.5.15 |
moodle/moodle Packagist | From 3.7.0 | 3.7.9 |
moodle/moodle Packagist | From 3.7.0 | 3.7.9 |
moodle/moodle Packagist | From 3.8.0 | 3.8.6 |
moodle/moodle Packagist | From 3.8.0 | 3.8.6 |
3 more packages
moodle/moodle Packagist | From 3.9.0 | 3.9.3 |
moodle/moodle Packagist | From 3.9.0 | 3.9.3 |
moodle Bitnami | From 3.5.0 | 3.5.15, 3.7.9, 3.8.6, 3.9.3 |
Products include Fedoraproject Fedora, Moodle Moodle.
How do I fix CVE-2020-25701?
Upgrade moodle/moodle to a fixed version for your release line: 3.5.15, 3.7.9, 3.8.6 or 3.9.3.
Is CVE-2020-25701 being exploited?
There is no known exploitation of CVE-2020-25701 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as BIT-moodle-2020-25701, GHSA-c9hq-g4q8-w893, UBUNTU-CVE-2020-25701.